互联网的伟大之处
在于每个人都在分享自己的知识

Cisco常用命令

常用(查看,登陆,VLAN)

// 常用

最开始:
> enable 
进入特权命令
# configuer terminal 
进入全局设置
# write
保存命令 
(config)# hostname [新名字]
修改主机名

查看各种信息:
# show ip route
查看路由表
#show running-config
查看全局配置

杂:
退出  exit
查看版本及引导信息 #show version
查看开机设置 #show startup-config
显示端口信息 #show controllers type slot/number
拷贝命令
将配置保存到 NVRAM: # copy running-config startup-config

改变状态命令
 进入特权命令状态> enable
 退出特权命令状态 disable
 进入设置对话状态 setup
 进入全局设置状态# configuer terminal

// 进入接口
(config)# interface [f/g/s]*/*
// 批量进入接口
(config)# interface range f0/1-12


// 配置特权模式密码
(config)# enable password [set password]

// 配置console口密码:
(config)# line console 0    // 配置控制口
(config-line)# password [password]    // 配置密码
(config-line)# login    // 开启密码生效

// 配置 telnet 远程登录密码 
(config)# line vty 0 4     //进入线程配置模式
(config-line)# password [setpassword]    // 配置 Telnet 的密码
(config-line)# login     // 启用 Telnet的用户名密码验证默认root
(config-line)# end     // 结束

// 配置多用户的telnet登陆
(config)# username zyxweb password [set password]  // 创建用户zyxweb,在[]内配置密码
(config)# line vty 0 4     //进入线程配置模式
(config-line)# login local   // 登陆使用本地账户
(config-line)# end     // 结束

!!!!!!!!!! 远程登陆必须满足三个条件特权密码,VTY密码,管理地址!!!!!!!!!!!!!!!!!!

// 加密所有密码
(config)# service password-encryption

// VLAN 
// 进入接口 配置接口为access并通过所有
(config)#interface [f/g]*/* 
(config-if)#switchport access vlan *
// 配置vlan别名
(config-if)# name [name]

// 进入接口 配置接口为trunk并通过所有
(config)#interface [f/g]*/*          
(config-if)#switchport mode trunk
(config-if)#switchport trunk allowed vlan all  

// 三层交换
启用三层交换
Switch(config)#ip routing

// 配置静态路由
(config-if)#ip route 目的网段 目的网段掩码 下一跳地址

// 配置三层vlan ip地址
interface vlan * 
ip  address *.*.*.* *.*.*.*


// 启动 MSTP
spanning-tree 

链路聚合

// 链路聚合  
先创建 port group
interface port-group 1
查看 创建的group
show enterchannel
手动
interface range GigabitEthernet 1/0/1-2 
switch(Config-Port-Range)#channel-group 1 mode on 
switch(Config)#interface port-channel 1 
LACP自动
interface ethernet 0/0/1-2 
switchA(Conifg-Port-Range)#port-group 1 mode active 
switchA(Config)#interface port-channel 1

RIP

(config)# router rip
(config-router)# version 2   // 设置版本
(config-router)#  network 192.168.30.0   // 宣告网段
(config-router)#  network 192.168.40.0   // 宣告网段 
(config-router)#  no auto-summary  // 不自动汇总, 都这么干, 之后我明白为啥了在解释

OSPF

(config)# router ospf 1  // 本地命名
(config)# router-id 1.1.1.1 // 命名 不能重复
(config-router)# network 192.168.10.0 0.0.0.255 area 0  
(config-router)# network 192.168.40.1 0.0.0.0 area 0
(config-router)# network 192.168.50.2 0.0.0.0 area 0
// 宣告网段及反掩码 还有区域, 同一区域才会发现

ACL

扩展访问控制列表:

access-list access-list number {permit/deny} protocol +源地址+反码 +目标地址+反码+operator operan(it小于,gt大于,eq等于,neq不等于。具体可?)+端口号

(config)# access-list 101 deny tcp host 192.168.10.3 host 192.168.20.2 eq www  
// 拒绝tcp 10.3到20.2的www协议
(config)# access-list 101 permit ip any any   // 必配
// 一定要记得去端口配置上
(config)# interface [f/g/s]*/*
(config-if)# ip access-group 101 in
!!!!  在最近的端口上配置

NAT

interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 60.145.1.1 255.255.255.0
 ip nat outside
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat pool zyx 60.145.1.5 60.145.1.6 netmask 255.255.255.0
ip nat inside source list 1 pool zyx
ip classless
赞(0) 打赏
未经允许不得转载:南涧之滨 » Cisco常用命令

评论 抢沙发

评论前必须登录!

 

觉得文章有用就打赏一下文章作者

非常感谢你的打赏,我们将继续给力更多优质内容,让我们一起创建更加美好的网络世界!

支付宝扫一扫打赏

微信扫一扫打赏